Kizashi Club

Your Kizashi Owners Club and Forum 

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
 #49393  by kizashi666
 Wed May 29, 2019 7:30 pm
hi, I'm the original owner, never had any real problems. I got the serpentine belt fixed Saturday, started up great for a few days, no CELs, but last night it didn't start up on the first try, this morning the same thing, I cleaned out the throttle body this morning, did not over saturate with cleaner, wiped off with a rag and allowed 10 min to dry. Then I started up, it took two attempts then started to idle higher from the throttle cleaning and after 30 seconds all the rattling noise started and the belt is shredded a decent amount and burning smell...they did not replace the pulleys or belt tensioner as they said they seemed fine. what could the cause be? like I said I haven't had any other issues, a/c ran fine
 #49501  by old tech
 Sun Jun 16, 2019 2:27 pm
Sorry for the late response . The belt tensioner is your problem . you can get a new one on ebay very cheaply. I can recommend Febest 0790-GRV. This is a silent killer of the Kizashi and should be changed out at 100k. The problem with it is a little hard to see but its at the pivot point, not the pulley bearing. It can be fixed by pressing back tight again and adding a grease fitting in a hole thats already there then lubing it and reset preload. A simple way to see the problem or check condition is to turn engine backwards( or counterclockwise) 6 revolutions while watching drive belt just above the crank pulley. It while start edging off and then jump a rib when its warn.
 #49716  by kizashi666
 Wed Jul 17, 2019 7:33 pm
yea it was toast, for several month it had been squealing letting off the brake, sounded just like brake squeal but it did go away after putting on a new belt then totally shredded days later. I did order the 30 dollar Chinese pulley but canceled after realizing they are garbage(they tend to last exactly 1 year). got a new OEM tensioner for 140....this is the only failure I've had since buying this sls in 7 1/2 years, id like to get at least 2 more years of lite daily driving out of it...also the car likes to randomly lock itself with the keys in the car
it has trouble starting after sitting for about 2-3 1/2 hours but starts right up after the first try, still on the factory spark plugs at 121k miles
 #49723  by bdleonard
 Thu Jul 18, 2019 2:46 pm
kizashi666 wrote:yea it was toast, for several month it had been squealing letting off the brake, sounded just like brake squeal but it did go away after putting on a new belt then totally shredded days later. I did order the 30 dollar Chinese pulley but canceled after realizing they are garbage(they tend to last exactly 1 year). got a new OEM tensioner for 140....this is the only failure I've had since buying this sls in 7 1/2 years, id like to get at least 2 more years of lite daily driving out of it...also the car likes to randomly lock itself with the keys in the car
it has trouble starting after sitting for about 2-3 1/2 hours but starts right up after the first try, still on the factory spark plugs at 121k miles


I'd say you're certainly due for a set of spark plugs, and might want to have the battery checked (if it has never been replaced). There was a TSB for long crank / fail to start on the 2010-2011s that involved an ECM update, but that does not apply to the 2012 or 2013.
 #49725  by kizashi666
 Thu Jul 18, 2019 7:34 pm
I've had issues with my sls cranking long, even a few months after buying new. its usually after it rains but now its really only when I drive and try to start after its been sitting about 2 hours always, last night I started after it was sitting for 3 1/2 hours and it started perfect. other than that......the cvt has whined since day one, no change, I tend to drive 'with' it, a.k.a driving like a grandma, NOT pushing it. I'm on my third battery, haven't had any recalls performed, got the letter about the dust filter that Suzuki said would 'fix' the recall...more or less them saying that the dust filter actually made it worse lol....I don't trust any 'dealer' thats left to removed the awd and replace the gas tank, place where I got it from was run by complete idiots