Kizashi Club

Your Kizashi Owners Club and Forum 

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
 #50957  by campus23
 Mon Jan 13, 2020 11:28 pm
Hello, I am asking you for help and advise on heating the rear window and exterior mirrors. for several days in my Kizashi after pressing the rear window heating button, nothing happens, the button does not turn yellow. in addition, the heating did not work. I checked the fuse in the engine compartment (15A) from heating and it's ok. I have no idea where to look for the problem? please tell me what I can do about it. Thank you in advance for your reply and any suggestions
 #50959  by SAEED_KIZZY
 Tue Jan 14, 2020 10:48 am
campus23 wrote:Hello, I am asking you for help and advise on heating the rear window and exterior mirrors. for several days in my Kizashi after pressing the rear window heating button, nothing happens, the button does not turn yellow. in addition, the heating did not work. I checked the fuse in the engine compartment (15A) from heating and it's ok. I have no idea where to look for the problem? please tell me what I can do about it. Thank you in advance for your reply and any suggestions

look for 30A RR DEF (rear defragger relay) fuse 17 this is the one that supplies both rear defragger and mirror heater.
 #50960  by Ronzuki
 Tue Jan 14, 2020 3:24 pm
Relay itself could be the culprit. Most automotive relays are not very well made, especially w/ the type of current they handle. Not sure where it is in the car, or a p/n, but my guess is that at 30A it's probably under the hood. If the fuse tests good w/ a meter, then the relay is the next item on the list. I've had bad relays blow fuses numerous times. I've taken a relatively new relay apart that was blowing fuses and it's in pieces inside. They're cheap enough to replace once you've located the correct one in the car.