Kizashi Club

Your Kizashi Owners Club and Forum 

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
 #51042  by LPSISRL
 Tue Jan 21, 2020 2:29 pm
Hey all,
A few days ago, all of a sudden, I started getting a strange smell inside the cabin when I started up my Kizzy. :shock: It smelled sorta electrical but then again, maybe not. I determined that the smell was coming from the vents. So I suspect the blower motor resistor/control module. I manually went through all the fan motor speeds and there is no change between the highest and second-highest. There is definitely a step between all the others. However, I don't know if the resistor/control module is actually in the airflow path to make the smell come out of the ducts. The motor itself seems fine. I'd appreciate your input as the module is about $125 at rockauto.com. If it is the module and I'm only missing top speed, I may just leave it if the smell goes away. Any thoughts on that as well?

Also, has anyone replaced theirs? Seems like it's pretty easy according to the manual.

Remove the lower passenger side cover
Remove the passenger side duct
Disconnect the module
Remove the controller/resistor module
Reverse

Thanks in advance to all you grizzled Kizashi veterans.
Tim
 #51045  by SAEED_KIZZY
 Tue Jan 21, 2020 4:59 pm
LPSISRL wrote:Hey all,
A few days ago, all of a sudden, I started getting a strange smell inside the cabin when I started up my Kizzy. :shock: It smelled sorta electrical but then again, maybe not. I determined that the smell was coming from the vents. So I suspect the blower motor resistor/control module. I manually went through all the fan motor speeds and there is no change between the highest and second-highest. There is definitely a step between all the others. However, I don't know if the resistor/control module is actually in the airflow path to make the smell come out of the ducts. The motor itself seems fine. I'd appreciate your input as the module is about $125 at rockauto.com. If it is the module and I'm only missing top speed, I may just leave it if the smell goes away. Any thoughts on that as well?

Also, has anyone replaced theirs? Seems like it's pretty easy according to the manual.

Remove the lower passenger side cover
Remove the passenger side duct
Disconnect the module
Remove the controller/resistor module
Reverse

Thanks in advance to all you grizzled Kizashi veterans.
Tim

Kizashi HVAC does not use a resistor to control blower fan speed it uses a special power transistor to control blower speed this transistor is located on blower fan control moule if the control module is damaged somehow fan stop working permanently.