2010 Suzuki kizashi service start system

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
Post Reply
Kizzy2010
Posts: 4
Joined: Mon Nov 20, 2023 11:12 pm

Hello I’ve recently bought a used kizashi and I’ve had it since February well it’s been running fine then one morning I went to start it and it wouldn’t start it only said service start engine I thought it was the key fob I’ve changed the battery in it and didn’t help then I also put a new battery in my car it finally started but wouldn’t stay running kept dying I drove it about 10 miles then it stalled while driving down the highway I was told it was the key fob cause it was saying key fob not detected so I got a new one but it say for a couple days and then wouldn’t start so I had it towed to get programmed but they can’t get any power to even reprogram a fob he is saying he thinks it’s electrical
User avatar
Obama_is_hot6
Posts: 139
Joined: Wed Oct 18, 2023 1:24 am

yeah ive had that same issue, for months everytime i start my car it says key fob not detected, but its never shut off the car once it initially turn on... somewhere on this website theres a post about how to reprogram your key fob ill try to find it
YUUUURT
Kizzy2010
Posts: 4
Joined: Mon Nov 20, 2023 11:12 pm

I have it at the shop to reprogram it but they can’t even get any power to do that which is making him think it’s electrical but it was driving fine the night before all this happened no lights came on or anything
User avatar
Obama_is_hot6
Posts: 139
Joined: Wed Oct 18, 2023 1:24 am

Kizzy2010 wrote: Mon Nov 20, 2023 11:34 pm I have it at the shop to reprogram it but they can’t even get any power to do that which is making him think it’s electrical but it was driving fine the night before all this happened no lights came on or anything
oh weird do you have a second key fob? you might have to buy a new one entirely. thats what fixed it for me . you can find them online for like 250 usd. you can buy some for cheaper but a trusted guy who owns minesota key and locksmith store told me not to go under 200 dollars because thoes are fakes or replicas that might not last as good as oem ones.
YUUUURT
Kizzy2010
Posts: 4
Joined: Mon Nov 20, 2023 11:12 pm

I didn’t have a 2nd key fob I bought one online a used one from eBay but exactly the same as the one I got
old tech
Posts: 723
Joined: Mon Apr 23, 2018 1:51 pm
Location: n/w pennsysvania

If you can’t get dash to light up you may have to feed battery power to fuse number 13 . Then check all fuses under dash and under hood.plug in scan tool and check all codes. You will need to check Tpms computer for trouble codes as this is where they hide the keyless start codes. Erase all codes and see if any codes come back. The service start system can light for many reasons . The starter itself is very easy to check. Pull starter relay and jumper it. Starter should crank engine over and sound normal. Tell me what codes came back and symptoms.


Sent from my iPhone using Tapatalk
Kizzy2010
Posts: 4
Joined: Mon Nov 20, 2023 11:12 pm

It’s at the point now where it won’t recognize the key fob and they can’t even reprogram it and the guy at the shop says he thinks it’s in theft mode and he tried a procedure he found online but it won’t let him do anything and I have no Suzuki dealers around me
old tech
Posts: 723
Joined: Mon Apr 23, 2018 1:51 pm
Location: n/w pennsysvania

Where is it you call home? It sounds like maybe your original problem has changed. Was the starter relay pulled and Jumpered to test the starter motor Originally you just had a service start. System icon. If your shop guy would like a little free assistance pm me a number and a good time to call


Sent from my iPhone using Tapatalk
Post Reply