Page 1 of 1

Which wiring harness fits 2011 SLS (Kenwood DNX6020UA3)?

PostPosted:Sat Jan 05, 2019 6:02 am
by cokizashi
Hi All,

I'm a new member to this forum.

I'm installing a new head unit in a 2011 Kizashi SLS (came with the Kenwood DNX6020UA3). I spoke to Crutchfield and they set me up with the following, that I received today:

1) Pioneer AVH-1440NEX (head unit)
2) Axxess ASWC-1 (steering wheel control adapter)
3) Scosche SI06B Wiring Interface (wiring harness)
4) Scosche SI2229B Dash Kit (dash trim piece)
5) Metra 40-HD10 Antenna Adapter (antenna adapter)

I followed the instructions provided by Crutchfield and pulled the Kenwood out. However, the Scosche wiring adapter (#3 above) does not fit the factory plug. In attached pictures A and B below, the white plug is the Scosche provided by Crutchfield and the black plug is the factory end (that plugged directly into the Kenwood). The holes of the black plug do not line up with the pins in white plug (none of the pins are bent, the adapters just are not the same).

Did Crutchfield send the wrong wiring adapter? Is there a better one that I should use? I really, REALLY want to avoid cutting the factory plug out to directly splice into the wires...

Thanks!

Re: Which wiring harness fits 2011 SLS (Kenwood DNX6020UA3)?

PostPosted:Sat Jan 05, 2019 6:41 pm
by SAEED_KIZZY
hi
I am not sure but I think:
Black connector is not factory end it is adapter to connect Kenwood HU to OEM connector follow black connector there must be Blue connector unplug it and you see will find mating connector for your new harness adapter.

Re: Which wiring harness fits 2011 SLS (Kenwood DNX6020UA3)?

PostPosted:Sat Jan 05, 2019 11:56 pm
by cokizashi
You were right!! I traced the wires from the black harness and sure enough, there was a white plug hidden by a bunch of foam tape. I disconnected the plug and it fits into the Scosche provided by Crutchfield.

Thanks for the help!

Re: Which wiring harness fits 2011 SLS (Kenwood DNX6020UA3)?

PostPosted:Tue Feb 05, 2019 11:06 pm
by smsmart
cokizashi, how'd the new headunit install go? Does everything work ok, steering wheel controls and all? Does the sound from the Rockford Fosgate speakers sound similar on the new HU as they did on the Kenwood? I have the same Kenwood headunit in mine and I'm thinking of doing an upgrade as well, especially so I can get CarPlay.