Page 1 of 1

P050A and P0335A - Idle Air Control Valve

PostPosted:Tue Jul 09, 2019 11:12 pm
by Dsp
Hello!

I'm having issues with my 2010 Suzuki Kizashi. It seems that the car is having issues idling properly. When started, it usually shoots up up about 1500 RPM before coming back down to 200-400, causing the car to vibrate, and then about 95% of the time, it goes back up to about 700RPM and idles there normally. The other 5% of the time, the car shuts off, and I need to start it again.

I've run an ODB Scanner and received the two codes listed in the title:

P050A - Idle Air Control Valve Sensor

P0355 - Powertrain

I've cleaned the throttle body, as per other recommendations for the P050A alert. However, I'd still like to check/replace the idle air control valve and sensor. I've so far been unable to locate it, and my Google searches have ended without any luck.

Does anyone have any other recommendations for how to resolve this issue? Can anyone provide me with a photo of the sensor/valve so I can search for it online? Or if anyone knows of where to get it, that'd be awesome.

Re: P050A and P0335A - Idle Air Control Valve

PostPosted:Wed Jul 10, 2019 7:04 pm
by bdleonard
As far as I know, there is no separate idle air control on the Kizashi. The idle is wholly handled by the ECM using the electronic throttle body. So long as the throttle body is clean, the wiring ok, and the throttle plate responds appropriately to the gas pedal, that probably isn't the issue.

Your other code is P0335 which the service manual states is "Crankshaft Position Sensor “A” Circuit" which if it or its wiring is malfunctioning can certainly be the cause of all of the problems you described.