Page 4 of 5

Re: How many NZ/Aus owners with cvt problems

PostPosted:Mon Mar 09, 2015 10:55 am
by TonusMcBronus
Mine is fine with 45K on the clock and so is my friend's with 40K on AWD model. Brilliant drive and unbeatable value.

Re: How many NZ/Aus owners with cvt problems

PostPosted:Tue Mar 10, 2015 7:09 am
by coref1
Agree, hard to beat for the money and I want to keep mine forever. Just trying to find out how much of a potential problem the cvt may be given previous issues particularly in North America.

Re: How many NZ/Aus owners with cvt problems

PostPosted:Tue May 19, 2015 10:40 am
by c.grantham
Hi. First time on the chat line
Got me an awesome Kizashi 2010
BUT just had it full service 150,000 kms
Cruised into me driveway and felt like I had a flat tyre, had enough speed to get into garage
Selected reverse gear did not move transmission shagged
Advised it was the primary cones in the transmission and will cost me $5995.00 plus tow truck driver
Help me
anybody had the same issues
Look forward to your reply.
NZ Chris


Sent from my iPad using Tapatalk

Re: How many NZ/Aus owners with cvt problems

PostPosted:Wed May 20, 2015 3:35 am
by Fritz2
Man, that's not good. Maybe at that price you could convert to a 6 speed manual trans? They appear to be fairly bulletproof. Easy to shift compared to some of the other manuals I've owned, as well.

Re: How many NZ/Aus owners with cvt problems

PostPosted:Wed May 20, 2015 10:45 am
by Woodie
What kind of powertrain warranty did you get ? Here in the States that would still be covered up to 160K km.

Re: How many NZ/Aus owners with cvt problems

PostPosted:Tue Jun 02, 2015 8:07 am
by c.grantham
Suzuki came to the party and paying half the repair price can't complain much better than nothing
Thanks Suzuki


Sent from my iPad using Tapatalk

Re: How many NZ/Aus owners with cvt problems

PostPosted:Wed Jun 03, 2015 10:56 am
by coref1
Hi Chris, Sorry to hear about your trannie problems but good to hear Suzuki are paying part of the cost. It be good if you could keep us all up to date on how the repairs go. Can you tell us did you just purchase your Kizzie or have you had it since new? Do you know if the trannie has been serviced before at all?

Re: How many NZ/Aus owners with cvt problems

PostPosted:Thu Jun 04, 2015 4:28 am
by c.grantham
Hi I have had me Kizashi since new, 2010 trannies not been touch except for oil changes will keep you informed


Sent from my iPad using Tapatalk

Re: How many NZ/Aus owners with cvt problems

PostPosted:Fri Jun 05, 2015 7:20 am
by coref1
This is the first cvt failure I've heard of from NZ/Aus Kizzie owners so hopefully it's not a sign of things to come. The cvt is probably the biggest concern with the Kizashi, it seems pretty reliable otherwise. With the northern hemisphere summer upon us I'll be interested to see if there are anymore cvt failures there.

Re: How many NZ/Aus owners with cvt problems

PostPosted:Sat Jul 04, 2015 11:08 am
by G13b
Lucky mine is manual tranny, to those who has issue with cvt maybe its an option to convert it to manual if you know how to drive one.

Sent from my GT-I9305T using Tapatalk