Kizashi Club

Your Kizashi Owners Club and Forum 

The Do It Yourself section is used provide assistance with mods and fixes. Whenever you are making a change to your car please take pictures and notes. Let others know what to watch out for and any useful tricks you learn. If you are starting a post in this section from scratch please hold it to a higher standard than you would for other forum posts. i.e. technical detail and even grammar.
Please post about issues or problems in the Technical Support & Problem Troubleshooting forum.
 #30034  by jcorcione
 Tue Jul 01, 2014 8:49 pm
I know this may be an old subject but i am needing a OEM part number for the 2013 Suzuki Kizashi SLS Garmin Infotainment Head Unit. Mine needs to be replaced, it is acting quite wonky! I updated the Nav SW as well as the Unit upgrade and I cannot speak an address into the unit, how ever it will recognize points of interest speech entry. VERY WEIRD.
 #30059  by sx4rocious
 Thu Jul 03, 2014 3:01 am
jcorcione wrote:I know this may be an old subject but i am needing a OEM part number for the 2013 Suzuki Kizashi SLS Garmin Infotainment Head Unit. Mine needs to be replaced, it is acting quite wonky! I updated the Nav SW as well as the Unit upgrade and I cannot speak an address into the unit, how ever it will recognize points of interest speech entry. VERY WEIRD.

to be completely honest, I have yet to find anyone that actually likes that unit. They put it in the SX4's too and I haven't found anyone in that forum that likes it either. You may actually just want to replace it (after the warranty is up) with an aftermarket unit, or downgrade to the lesser RF model and buy an outboad GPS. By the sounds of things, it may save you money in the long run...
 #30060  by murcod
 Thu Jul 03, 2014 4:51 am
Yes, I'd agree. You've got the double DIN fascia, so if you're out of warranty perhaps do some shopping around? It obviously won't be the easiest option (ie. installation wise with wiring), but for audio quality you'd be miles ahead.

Otherwise, I'd be looking at wrecked vehicles. I believe that head unit is common on a number of Suzuki vehicles (like the SX4 already mentioned.) You might even find someone wanting to offload one cheap because they're upgrading to an aftermarket unit. ;)

This may be of assistance: http://clubsx4.com/forum/showthread.php?t=4546
 #30150  by ms_enj
 Tue Jul 08, 2014 5:26 am
sx4rocious wrote:
jcorcione wrote:I know this may be an old subject but i am needing a OEM part number for the 2013 Suzuki Kizashi SLS Garmin Infotainment Head Unit. Mine needs to be replaced, it is acting quite wonky! I updated the Nav SW as well as the Unit upgrade and I cannot speak an address into the unit, how ever it will recognize points of interest speech entry. VERY WEIRD.

to be completely honest, I have yet to find anyone that actually likes that unit. They put it in the SX4's too and I haven't found anyone in that forum that likes it either. You may actually just want to replace it (after the warranty is up) with an aftermarket unit, or downgrade to the lesser RF model and buy an outboad GPS. By the sounds of things, it may save you money in the long run...


I like it.

Or at least, I like the interface, functionality, and the styling and OEM appearance of the unit.

I don't like the fact it's got a very high noise floor.

Mine is now running through a Rockford Fosgate 3sixty.3 processor to integrate with the factory RF system, which works well. Being infinitely tunable is a definite plus.

Image

As it is, I'm finding the factory amp driving the subwoofer means I can't tune or time align it seperately, so I'm going to install a second, stand alone amplifier just to drive the sub directly from the processor.
 #30151  by murcod
 Tue Jul 08, 2014 7:18 am
I don't think you'd be as happy with the Garmin unit as it comes from the factory (ie. with no RF amp or speakers to back it up.)

You've also spent a considerable amount of time / money modifying both the Garmin and the RF system .... with more mods to come!

The Rockford Fosgate 3Sixty.3 processor alone appears to be around US$600 ! http://www.crutchfield.com/S-wWknodzE62 ... xty-3.html :shock:
 #30203  by sx4rocious
 Wed Jul 09, 2014 2:30 am
murcod wrote:I don't think you'd be as happy with the Garmin unit as it comes from the factory (ie. with no RF amp or speakers to back it up.)

You've also spent a considerable amount of time / money modifying both the Garmin and the RF system .... with more mods to come!

The Rockford Fosgate 3Sixty.3 processor alone appears to be around US$600 ! http://www.crutchfield.com/S-wWknodzE62 ... xty-3.html :shock:

Completely agree here! I can make a cheap wal-mart system sound passible with proper signal processing. In the end, the interface is about the only thing you're still using in the unit. There are several threads in this forum and the SX4 forum that state various problems wih it. I love the factory RF unit in my wife's car. It's hands-down the best factory system I've owned, and top 5 compared to any factory system I've heard. I've always considered myself an audiophile and even used to own my own shop back in the 90's. I have a buddy with the Garmin unit in his SX4 that was a near $2k upgrade. He actually offered to trade it to me for my base model factory Panasonic unit at one time because he hated the unit so much. I'm glad you like yours, but not many people are willing to go to the lengths you have to make it work right...
 #30551  by Dave
 Mon Jul 28, 2014 9:15 am
Hi there . Need to seek advise from anyone, just purchased an old stock Suzuki Kizashi sport (New). I opted for a headunit replacement which has Navi, Reverse cam,etc but after installing it my factory sub woofer is not working. Any idea what can go wrong ? The installer said the new head unit does not have additional wire to the harness to support the sub. How can i make the sub work ? Thank you
 #30619  by ms_enj
 Thu Jul 31, 2014 1:34 am
Dave wrote:Hi there . Need to seek advise from anyone, just purchased an old stock Suzuki Kizashi sport (New). I opted for a headunit replacement which has Navi, Reverse cam,etc but after installing it my factory sub woofer is not working. Any idea what can go wrong ? The installer said the new head unit does not have additional wire to the harness to support the sub. How can i make the sub work ? Thank you


What country are you in, and is the original system in your Kizashi amplified?

(i.e does it have the Rockford Fosgate logo plastered everywhere)
 #30634  by Dave
 Thu Jul 31, 2014 9:25 am
Dear ms_eng, Thanks for responding. I am from Malaysia. I am not to sure whether is it amplified. No Rockford Fosgate system logo plastered and verified by Suzuki Malaysia. But i believe it should have a factory amp installed to support 8 speaker system.
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 8