Page 1 of 2

install aftermarket amplifier on Kizashi base without Rockford system

PostPosted:Tue Jan 01, 2019 1:24 pm
by SAEED_KIZZY
I decided to upgrade my kizashi/2012 Base model and it turns out huge upgrade for my car I Use 520W 4 channel Pioneer Amplifier for speakers and use OEM speakers with no change.
and also I use KAC-8106D sub-woofer amplifier for Pioneer TS-W261D4 subwoofer and use Box for that.
here is some picture of system on trunk.

Add OEM Subwoofer to kizashi

PostPosted:Sun Feb 10, 2019 8:46 am
by SAEED_KIZZY
Hi
- After install amplifier time to add sub-woofer to my car this time use OEM sub-woofer so I ordered some parts from
http://www.Megazip.net (also ordered Auto-light and rain sensor module for my next project :) )

photo_2019-02-10_10-55-29.jpg
photo_2019-02-10_10-55-29.jpg (102.94 KiB) Viewed 1959 times


- OEM subwoofer is not Rockford sub but it is good enough for me. I have to cut a hole in back of my trunk not so hard i think.

photo_2019-02-10_10-55-11.jpg
photo_2019-02-10_10-55-11.jpg (63.85 KiB) Viewed 1959 times



- Thanks to suzuki they add wire for sub woofer with connector that fits OEM sub so I use it but little modification.
photo_2019-02-10_10-55-08.jpg
photo_2019-02-10_10-55-08.jpg (52.45 KiB) Viewed 1959 times


- and finally use 4 screws to mount sub in predefined place.

photo_2019-02-10_10-55-26.jpg
photo_2019-02-10_10-55-26.jpg (68.17 KiB) Viewed 1959 times

Re: install aftermarket amplifier on Kizashi base without Rockford system

PostPosted:Thu Feb 14, 2019 1:09 am
by aranciata-oz
Hi Saeed,

Looks good. A few questions if you don't mind:

- where does the existing Suzuki subwoofer wire head back to? The side of the boot (where the Rockford amp would have sat) or all the way back to the head unit?
- also what signal did you feed the 4-channel amp? Via those yellow RCA's from the head unit? Or via inputs from the existing speakers?

Re: install aftermarket amplifier on Kizashi base without Rockford system

PostPosted:Sun Feb 17, 2019 6:41 pm
by SAEED_KIZZY
hi aranciata-oz,

as you can see in below schematic 2 wires are used to send subwoofer signal from HU to subwoofer: GREY and GRN/YEL
New Bitmap Image.jpg
New Bitmap Image.jpg (109.19 KiB) Viewed 1835 times

and in my car
photo_2019-02-17_20-50-28.jpg
photo_2019-02-17_20-50-28.jpg (61.21 KiB) Viewed 1835 times

I replaced OEM headunit with aftermarket android unit(ATOTO A6) and also use Kenwood amplifier so I cut these 2 wires and send it to Kenwood amplifier which I placed it on OEM AMP spot(which you can see on my previous post) and send it back to subwoofer.

In 4 channel amp I used same process, RCA output of my HU and send it Poineer amplifer and send it back to my HU and connect those wires to OEM connector (G248)

photo_2019-02-17_21-05-40.jpg
photo_2019-02-17_21-05-40.jpg (134.22 KiB) Viewed 1835 times

Re: install aftermarket amplifier on Kizashi base without Rockford system

PostPosted:Mon Feb 18, 2019 12:30 am
by aranciata-oz
Thank you so much Saeed! Great information.

Re: install aftermarket amplifier on Kizashi base without Rockford system

PostPosted:Sat Feb 23, 2019 11:57 am
by aranciata-oz
Another question Saeed ... where did you source your power for both amps? Did you run a fused power cable directly to the amp/s? If so, where did you run the through the car ie. which side of the car/under which carpet etc?


Sent from my iPhone using Tapatalk

Re: install aftermarket amplifier on Kizashi base without Rockford system

PostPosted:Sun Feb 24, 2019 3:11 am
by SAEED_KIZZY
aranciata-oz wrote:Another question Saeed ... where did you source your power for both amps? Did you run a fused power cable directly to the amp/s? If so, where did you run the through the car ie. which side of the car/under which carpet etc?


Sent from my iPhone using Tapatalk

I get battery power from Relay Box No.2(below glove box) as you can see in below picture fuse 71(20A) is dedicated for Rockford AMP but in my car there is no power on it so I use Fuse 61 and get power from it.
New Bitmap Image.jpg
New Bitmap Image.jpg (109.06 KiB) Viewed 1673 times

and route this wire through side of the car along with main floor harness in right side ( my car is LHD) you can see in blow picture.
New Bitmap Image.jpg
New Bitmap Image.jpg (121.85 KiB) Viewed 1673 times

Re: install aftermarket amplifier on Kizashi base without Rockford system

PostPosted:Mon Feb 25, 2019 1:32 am
by aranciata-oz
Thanks again Saeed - I'll check this out!

Re: install aftermarket amplifier on Kizashi base without Rockford system

PostPosted:Mon Feb 25, 2019 7:59 am
by SAEED_KIZZY
aranciata-oz wrote:Thanks again Saeed - I'll check this out!

you are welcome. :D

Re: install aftermarket amplifier on Kizashi base without Rockford system

PostPosted:Fri May 10, 2019 2:16 pm
by SAEED_KIZZY
I have an idea to add rear center speaker to my kizashi so I bought front center speaker from megazip
39102-57LD0-000 SPEAKER ASSY,CTR, Suzuki
and install it on back of my car beside subwoofer.
photo_2019-05-10_17-40-55.jpg
photo_2019-05-10_17-40-55.jpg (93.26 KiB) Viewed 941 times


and for wiring I use both positive wire of R,L rear speaker to create center speaker wire

photo_2019-05-10_17-41-57.jpg
photo_2019-05-10_17-41-57.jpg (145.57 KiB) Viewed 941 times