Kizashi Club

Your Kizashi Owners Club and Forum 

Introduce yourself here, also we will post links to topics we find the most valuable on the forum to help out new members.
 #2653  by ThunderSky
 Fri Aug 20, 2010 12:06 am
Bluetooth and Blackberry problems

My wife is having problems using the bluetooth system with her Blackberry Curve. It pairs up fine and works well sometimes, but then other times the radio sound cuts off (usually when the phone is not even being used).
The only way to get the radio sound back is to shut off the car and re-start it.
We have been trying to figure it out but it seems to be related to the Blackberry. So far it appears that something goes screwey when the blackberry receives an e-mail while connected to the car's bluetooth system.

The dealer said he heard something about issues with the Blackberry. He's sending Suzuki an e-mail.
Hopefully they will have some ideas.
 #2795  by metatrox
 Wed Aug 25, 2010 10:58 pm
iPhone 4 : Bluetooth audio and phone work. USB works. Mapquest GPS directions work over both.

iPad : Bluetooth audio(no phone of course) works. USB on iPad doesn't work. Says "error 1".
 #2924  by quickzilverfox
 Thu Sep 02, 2010 4:04 am
Samsung SWAY works fine, but no phonebook push
Blackberry 8900 has some crackle on phonecalls and only sees as HF device, no phonebook push
 #2975  by ThunderSky
 Sun Sep 05, 2010 6:45 pm
ThunderSky wrote:Bluetooth and Blackberry problems

My wife is having problems using the bluetooth system with her Blackberry Curve. It pairs up fine and works well sometimes, but then other times the radio sound cuts off (usually when the phone is not even being used).
The only way to get the radio sound back is to shut off the car and re-start it.
We have been trying to figure it out but it seems to be related to the Blackberry. So far it appears that something goes screwey when the blackberry receives an e-mail while connected to the car's bluetooth system.

The dealer said he heard something about issues with the Blackberry. He's sending Suzuki an e-mail.
Hopefully they will have some ideas.


Well, new amplifier installed last week and everything is working fine now.
They also did a couple of the recalls (storage compartment door and CVT computer) and we had the undercoating done at the same time.
 #4064  by Provolone
 Tue Nov 16, 2010 8:20 am
I have an HTC Touch Pro 2 with Spring PCS service. It "works" with the Bluetooth, but friends say it sounds like I'm talking on a drive-thru speaker. They complain enough that I simply can't use the Bluetooth -- which is the only reason I bought the fully-loaded model that had the Nav system and Bluetooth. Love my Kizashi, HATE the audio. AM doesn't work. AUX won't work with my IPod. But I don't think those are connected to my Bluetooth problem. Anyone else have this problem? Troubleshooting ideas?
 #4072  by autopiolet
 Wed Nov 17, 2010 3:50 am
I have an HTC EVO and the Blue tooth works for me, at least no one has said anything about the sound quality. The sound quality on my phone isn't great to begin with so I wonder if it is the phone and not the audio blue tooth. I stream music from my phone through the blue tooth and it sounds like a CD.
 #4136  by sosa
 Fri Nov 19, 2010 10:32 pm
Provolone wrote:I have an HTC Touch Pro 2 with Spring PCS service. It "works" with the Bluetooth, but friends say it sounds like I'm talking on a drive-thru speaker. They complain enough that I simply can't use the Bluetooth -- which is the only reason I bought the fully-loaded model that had the Nav system and Bluetooth. Love my Kizashi, HATE the audio. AM doesn't work. AUX won't work with my IPod. But I don't think those are connected to my Bluetooth problem. Anyone else have this problem? Troubleshooting ideas?


I have same problems on Nav system. No AM channels, AUX sucks, and no audio streaming through BT, i mean A2DP option. iphone 3G works fine through adapter. BlackBerry works fine as a phone.
 #4150  by Ronzuki
 Sat Nov 20, 2010 7:50 pm
Just paired an LG Flare LX165 phone w/ the car. Virgin Mobile service (rides on Sprint PCS's network).

This phone and Virgin Mobile's service are not listed in Suzuki's list referrenced in earlier post.
 #4193  by sosa
 Mon Nov 22, 2010 5:12 pm
sosa wrote:
Provolone wrote:I have an HTC Touch Pro 2 with Spring PCS service. It "works" with the Bluetooth, but friends say it sounds like I'm talking on a drive-thru speaker. They complain enough that I simply can't use the Bluetooth -- which is the only reason I bought the fully-loaded model that had the Nav system and Bluetooth. Love my Kizashi, HATE the audio. AM doesn't work. AUX won't work with my IPod. But I don't think those are connected to my Bluetooth problem. Anyone else have this problem? Troubleshooting ideas?


I have same problems on Nav system. No AM channels, AUX sucks, and no audio streaming through BT, i mean A2DP option. iphone 3G works fine through adapter. BlackBerry works fine as a phone.


I also have the same problem with Nav System. No AM, No audio streaming like you have for A2DP system, iphone 3G and BB work great. Also Nav system uses less speakers - it uses only 6 out of 10 speakers. Suzuki needs to find a compatible nav system which works with AM/ FM/10-speakers and has A2DP options.
 #4810  by chest3r
 Sat Jan 08, 2011 7:26 pm
My HTC Incredible works well. I've noticed sometimes if I accidentally turn bluetooth off on my phone and back on, it doesn't re-pair automatically. Phone, Audio, no phonebook.

*EDIT The stereo can't read my phonebook directly but contacts can be sent from my phone to the stereo's phonebook.
Last edited by chest3r on Sun Mar 13, 2011 1:38 am, edited 1 time in total.