Kizashi Club

Your Kizashi Owners Club and Forum 

Where DIYs with photos live. Please start new topics in DIY section. Completed DIYs are moved here for clutter control and quicker reference.
 #21021  by murcod
 Sat Oct 19, 2013 7:58 am
Thanks!

It's surprisingly small - only 132Mb. I'll post up when I've down loaded and tried it.
 #21023  by murcod
 Sat Oct 19, 2013 8:26 am
Downloaded okay. Unzipped and found the "readme", then found the index.html and opened that using Firefox. The page came up, but the LHS index area isn't populated, attempting to click on the top options (eg. bookmarks, index, DTC, search etc - above the index column) doesn't do anything?

I haven't got a lot of time to experiment at the moment- so it might be finger problems at my end?

Thanks again! :)
 #21024  by avluis
 Sat Oct 19, 2013 10:14 am
What is your OS? I know Windows 7, 8 & 8.1 were having issues displaying the pages. Had to use a virtual machine to get it working there.
But if you have Windows 7 Pro, I believe you get an XP virtual machine for free. Or you can use IIS 7 to host the pages.
Sorry I can't help you more here. This is one of the shortfalls of the web version.

Quick Edit: I have found the files responsible for the web manual not loading in Chrome and so often issues in Firefox as well.
I should have this fixed and a new update, working (offline) manual (hopefully) for all.
 #21025  by murcod
 Sat Oct 19, 2013 11:20 am
I'm running Windows 7 Home Premium 64bit. Virtual XP isn't an option for this version.

By IIS 7 do you mean this software : http://www.iis.net/ ? You're losing me a bit with all the software/ protocol talk.... The version on your server worked fine?
 #21026  by avluis
 Sat Oct 19, 2013 3:02 pm
murcod wrote:I'm running Windows 7 Home Premium 64bit. Virtual XP isn't an option for this version.

By IIS 7 do you mean this software : http://www.iis.net/ ? You're losing me a bit with all the software/ protocol talk.... The version on your server worked fine?


Yep, you are along the right track. IIS7 is what you want on windows.
You can use that website or go the control panel options.
If you don't want to mess with that then I am working on a quick and easy version of the offline files that will fix many of the issues.
Only requirement is Python, which is a free download.
The script I am working on will set up a server where the files are and avoid having to set up a server of your own and all. This will take care of many of the bugs but you will still need to be using Firefox until the many bugs I've found so far are fixed.
 #21038  by murcod
 Sun Oct 20, 2013 12:51 am
Okay, I found where to enable it in the Windows options and now have IIS7 "running"; what do I need to do to get it working with the service manual? (I'm still having the same issues.)
 #21039  by avluis
 Sun Oct 20, 2013 1:11 am
murcod wrote:Okay, I found where to enable it in the Windows options and now have IIS7 "running"; what do I need to do to get it working with the service manual? (I'm still having the same issues.)

You have to move the folders Top and Xml into a folder that IIS 7 created. It is usually C:\Inetpub
Delete whatever files are in this folder then put the folders I mentioned earlier in there then open Firefox and browse to:
http://localhost/Xml/SAW10A/

This should load it properly.
Please let me know if you have any other issues, I am working on the instant server so that should get you running if IIS does not.
 #21041  by murcod
 Sun Oct 20, 2013 5:53 am
Still no joy.

Error Summary
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information
Module IIS Web Core
Notification Unknown
Handler Not yet determined
Error Code 0x80070003
Config Error Cannot read configuration file
Config File \\?\C:\inetpub\wwwroot\web.config
Requested URL http://localhost:80/Xml/SAW10A/
Physical Path
Logon Method Not yet determined
Logon User Not yet determined


There is no "C:\inetpub\wwwroot\web.config" folder or file present
 #21043  by avluis
 Sun Oct 20, 2013 6:17 am
murcod wrote:Still no joy.

Error Summary
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information
Module IIS Web Core
Notification Unknown
Handler Not yet determined
Error Code 0x80070003
Config Error Cannot read configuration file
Config File \\?\C:\inetpub\wwwroot\web.config
Requested URL http://localhost:80/Xml/SAW10A/
Physical Path
Logon Method Not yet determined
Logon User Not yet determined


There is no "C:\inetpub\wwwroot\web.config" folder or file present


LOL, IIS wants you to set it up before you can even host a simple set of pages.

Do me a favor and see if you have python installed.
If not, go to http://python.org/download/ and grab version 2.7.5 for your build of Windows.
Go ahead and install that setup file.
I am making a bat file for you to add to the extracted folder so that it runs on its own server.

Just need to know a few things.
Your OS, is it Windows 7 or higher and is it x86 or x86-64? (32bit or 64bit)

Sorry for all the trouble, but I am staring at it working on a system without internet and would love for you to have it as well.
 #21045  by murcod
 Sun Oct 20, 2013 1:12 pm
My OS is Windows 7 64 bit.

I've downloaded Python, do I just let it install to it's own default folder or somewhere else?