Kizashi Club

Your Kizashi Owners Club and Forum 

Where DIYs with photos live. Please start new topics in DIY section. Completed DIYs are moved here for clutter control and quicker reference.
 #38473  by Ronzuki
 Mon Sep 28, 2015 5:33 pm
:lol: allow me to rephrase....any of us 'cept WESHOOT.
 #39567  by dslatsh
 Sat Jan 02, 2016 12:29 am
I know it's been a couple months now but has anyone figured anything else out about the suspension? I have a 2011 awd sls sport. Was kind of worried about having to replace the rear because of the issues they had and of course my car is out of warranty. When checking the brakes etc noticed some stuff on the suspension not 100% sure was leaking or if was dirt etc so in case of course I need replacements in the future wanted to know what's my best move. Thanks
 #39635  by bootymac
 Tue Jan 05, 2016 9:32 am
dslatsh wrote:I know it's been a couple months now but has anyone figured anything else out about the suspension? I have a 2011 awd sls sport. Was kind of worried about having to replace the rear because of the issues they had and of course my car is out of warranty. When checking the brakes etc noticed some stuff on the suspension not 100% sure was leaking or if was dirt etc so in case of course I need replacements in the future wanted to know what's my best move. Thanks

Rear shocks are likely leaking. Get the KYBs and revised bump stops or modify the existing ones
 #39652  by Juan
 Tue Jan 05, 2016 11:10 pm
I'm in the process of replacing my rear shocks with the kyb ones I got at my local Napa. I ordered the upgraded bumps at the dealer. I'm waiting for a warmer day here in the east coast ....
 #39671  by KuroNekko
 Wed Jan 06, 2016 10:43 pm
dslatsh wrote:The shocks they're listing say "shock W/O AWD, W/ Sport. My vehicle is a SLS AWD sport...I can't find any that says W/ AWD or does it not matter?


Does not matter. See first post in thread for details.
 #39681  by FrankoLaMoya
 Thu Jan 07, 2016 2:04 pm
Hey KuroNekko..Does it apply to the 2012 Canadian model? I am currently at 57 000 km (warranty of 60 000 km here in Canada) and there is like a clunk sound coming from the rear every time I go over a bump...could it be this or most likely a sway bar link or something like that?