Kizashi Club

Your Kizashi Owners Club and Forum 

If it has an S on the front you can talk about it here.
 #49532  by Ronzuki
 Sat Jun 22, 2019 10:06 pm
First drain of factory fill. 54,816 miles. Wife drives like a grandma. Same Jatco trans as the Kizashi however, the SX4 is much lighter and less powerful than the Kizashi.

IMG_1793 (Medium).JPG
IMG_1793 (Medium).JPG (89.75 KiB) Viewed 578 times


I will say it was much cleaner than the last of the 3 drain/fills I'd done on the Kizashi at ~80k miles last fall. I could see through the fluid as it was draining w/o too much difficulty. More of a pain in the azz to get to the cartridge filter though. Only doing a single drain fill on this one. battery and battery tray had to come out. ECM is attached to battery tray as well.

IMG_1794 (Medium).JPG
IMG_1794 (Medium).JPG (144.39 KiB) Viewed 576 times
 #49536  by Woodie
 Sun Jun 23, 2019 12:36 pm
I'm pretty sure that in the United States the J20 was only engine available in the SX4.
 #49537  by Ronzuki
 Sun Jun 23, 2019 1:21 pm
Yes correct, 2.0.

After letting it cool down overnight, post hi-speed / hi-R's / manual shift test romp, it appears I overfilled it a tad bit...setting the level from an overfill sucks...literally.

IMG_1795 (Medium).JPG
IMG_1795 (Medium).JPG (129.59 KiB) Viewed 538 times

IMG_1796 (Medium).JPG
IMG_1796 (Medium).JPG (154.57 KiB) Viewed 538 times


I suppose this is how one can "inspect" the fluid's condition per service manual. I personally prefer just draining it, as this method is painfully slow and really, really...sucks.