Kizashi Club

Your Kizashi Owners Club and Forum 

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
 #51142  by CasualKizashi
 Mon Feb 03, 2020 1:11 am
Hello everyone. I'm having trouble with 9the lock/unlock button on the driver door. (2011 SLS)

It only works some of the time, and has been getting worse since it started this week. The passenger door works just fine, but I have to push the driver one many times to open, if if does at all. I'm just using the fob now to avoid the hassle.

Has anyone had this issue? Could it be a wiring problem or a sensor? How would you suggest tackling this without having to spend a bunch to have it replaced at the shop?

Thank you all, I appreciate your help.
 #51147  by Ronzuki
 Mon Feb 03, 2020 8:05 pm
mechanical switches wear out, plain and simple. Just wondering, the one on the outside door handle of the car or the interior switch?
 #51164  by Ronzuki
 Tue Feb 11, 2020 1:54 am
The switch, w/ its (2) short connectored pigtails, is part of the front door handle (p/n 82810-57810-your car's paint_code) and not called out separately in the parts book I have. Same p/n handle for both driver & passenger side doors. Looks like you'd have to replace the entire handle assembly. Therefore, I'd look for a salvage yard handle from a car same paint code as yours. You'll obviously need to access the mtg hardware from inside the door.