Kizashi Club

Your Kizashi Owners Club and Forum 

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
 #51344  by tylerw1
 Mon Mar 23, 2020 5:08 pm
Hey everyone,

I love my Kizashi as we all do but my god do I have the ultimate lemon. I've been dealing with a bunk steering wheel lock for years, I've become pretty used to being stranded in very inconvenient situations.

The MORE in the title though is that while driving nearly all warning lights on the dashboard light up, power steering, hill assist, AWD, all stop working, and the car will not shut off without holding down the start button for a few seconds. Basically I have to do a hard reset it seems, like the ecu is freezing up? I know very little about car electronics and ecus, clearly.

Any ideas? I love this car but with a newborn I need to either get rid of it or be very sure I can fix it.

Thanks for any replies,
 #51345  by old tech
 Mon Mar 23, 2020 6:09 pm
Where are you located ? On steering lock, i would like to try replacing a motor inside the unit to see if its the trouble spot inside the ESL. This would be the cheap repair. Installing a brand new ESL is the correct repair and need before fixing a possible second fault .
 #51346  by tylerw1
 Mon Mar 23, 2020 6:19 pm
old tech wrote:Where are you located ? On steering lock, i would like to try replacing a motor inside the unit to see if its the trouble spot inside the ESL. This would be the cheap repair. Installing a brand new ESL is the correct repair and need before fixing a possible second fault .


British Columbia, Canada. I'm not quite ready to pull it apart yet as I'm waiting on back surgery, do you think the motor in the unit is accessible to purchase in Canada for a regular consumer?
 #51347  by old tech
 Mon Mar 23, 2020 6:31 pm
No, the only way for just a motor is yanking it out of a used steering lock. The whole used ESL cant be reused in a different car due to how it was programmed. You should probably get a new one. Around $250 I think
 #51348  by tylerw1
 Mon Mar 23, 2020 6:41 pm
Thanks for your help old tech I appreciate the info, I'll be replacing it with a new one, I think there's a few good threads on this forum on replacing this part.

If anybody has any ideas about my second problem or has experienced similar issues please let me know.
 #51353  by Ronzuki
 Tue Mar 24, 2020 1:56 am
I believe what OldTech is eluding to (please correct me if I'm wrong here OT) is that the steering lock's electro-mechanical problem could possibly be causing the other flakey issues. Fix the known problem first and the remainders may heal themselves, or present differently. If it were simply the crazy dash light syndrome w/o the steering lock problem, I'd be thinking power problems...battery, wiring, or ground issues. The bad steering lock could create those type of issues for the electronics. Or there's a fuse open somewhere. The fuses going open in these cars have produced some bizarre results if ya ask me.
 #51357  by tylerw1
 Tue Mar 24, 2020 4:42 am
Ah gotcha, that makes sense, I'll have to order the part. In the meantime I'll check the battery and fuse boxes, I've had to replace a fuse for the taillights before so I'm really curious if maybe I knocked something loose in the fuse box. Thanks guys