Kizashi Club

Your Kizashi Owners Club and Forum 

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
 #49258  by GRKIIING'S
 Wed May 08, 2019 12:04 am
Hello I'm new on this forum trying to find an answer for my 2012 sls kizashi awd so here I go I got this car last year never been able to drive it I took it to a mechanic and replace the transmission 3times already and he said there nothing else he can do also he said the transmission control module (TCM) need to be reflash or reprogram I drive the car last week for 20min and I'll dashboard lights turn on like a Christmas tree but still driveable and I can't go more than 60mph doesn't overheated or anything I'm trying to find answers i can't afford to take it to a dealership right any info or help would be appreciated it thank you.
 #49259  by old tech
 Wed May 08, 2019 4:23 am
First I would recommend retrieving codes for both engine and trans. write it down. try erasing codes. See what doesnt erase or comes back right away. There should be no reason to have to see a dealer over a transmission replacement. The rom (2in square block on the valve body) should have been transferred over to the donar tranny and probably is your problem. P1825 I think. If you no longer have it , you can get this to work but it sometimes is very stubborn . Try again erasing codes disconnect large square plug on trans erase again, plug back in erase again check codes.
 #49296  by GRKIIING'S
 Wed May 15, 2019 4:42 am
GRKIIING'S wrote:Hello I'm new on this forum trying to find an answer for my 2012 sls kizashi awd so here I go I got this car last year never been able to drive it I took it to a mechanic and replace the transmission 3times already and he said there is nothing else he can do also he said the transmission control module (TCM) need to be reflash or reprogram I drive the car last week for 20min and all dashboard lights turn on like a Christmas tree but still driveable and I can't go more than 60mph doesn't overheat or anything I'm trying to find answers i can't afford to take it to a dealership right now any info or help would be appreciated it thank you.




Sent from my LG-H931 using Tapatalk