Blower motor???

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
Post Reply
User avatar
honsonwong
Posts: 196
Joined: Mon May 06, 2013 6:01 am
Location: B.C. Canada

After starting up my Kizashi for 5-6 minutes, I could hear a hissing sound coming from the air vents. Is this due to a problem with the blower motor or elsewhere? Any ideas or suggestions are welcome.
old tech
Posts: 326
Joined: Mon Apr 23, 2018 1:51 pm
Location: n/w pennsysvania

I think what you are hearing is the air conditioning . This may be louder than normal because of incorrect charge level. If the blower motor is actually making a strange noise, you should be able to confirm the naughty blower by selecting different speeds.
User avatar
honsonwong
Posts: 196
Joined: Mon May 06, 2013 6:01 am
Location: B.C. Canada

Does this mean I may need to re-fill the refrigerant? I will also try selecting different speeds to see if the sound will get louder. Thank you!
User avatar
honsonwong
Posts: 196
Joined: Mon May 06, 2013 6:01 am
Location: B.C. Canada

Just an update!!
I checked the following
when I changed the speed of the fan, no difference in the hissing sound
when I lowered the temperature of the AC, hissing sound got louder
when I lowered the temperature to LO, several minutes later, it was still not cold
When I turned off the AC, the hissing sound was gone, I could only hear the sound of the air flow

In this case, I think the blower motor is fine, but don't know if it's because the refrigerant has leaked. There is also a strange smell from the air vent.

Any ideas and suggestions are welcome!! Thanks.
User avatar
honsonwong
Posts: 196
Joined: Mon May 06, 2013 6:01 am
Location: B.C. Canada

Updating.
I have refilled the freon (refrigerant) and the hissing sound was gone. Old tech was right, thank you.
Post Reply