Kizashi Club

Your Kizashi Owners Club and Forum 

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
 #48645  by nkerr22
 Thu Jan 10, 2019 9:04 am
I just got a 2012 Suzuki Kizashi Sport SLS AWD with 80,000 miles. When I drive over 55 MPH, there is a very noticeable vibration throughout the steering wheel, dashboard, and under my feet. It seems to mostly go away when I go around bends and corners at the same speed, or while I am going up a hill sometimes. Tires were replaced by last owner around 55,000 miles. They seem to look good but that doesn't mean a lot. Just passed inspection, etc. two days ago so wondering if I should get an alignment or start looking at new tires. Any help would be appreciated.
 #48646  by nkerr22
 Thu Jan 10, 2019 9:06 am
There is also a lot of shaking when stopped at a stop light, etc. Idling seems more rocky than usual.
 #48651  by WESHOOT2
 Thu Jan 10, 2019 3:01 pm
1) 40 gallons of Mobil (or Exxon) premium

2) have your tires balanced

3) wash the underneath thoroughly

4) something else.......
 #48653  by LPSISRL
 Thu Jan 10, 2019 4:33 pm
Clean the throttle body. Easy do-it-yourself. Takes less than an hour. I used SeaFoam to clean mine and it worked a lot better than carb/choke cleaner.
 #48657  by KuroNekko
 Thu Jan 10, 2019 9:59 pm
I agree with the suggestions of the others. For the vibration at speed, check wheel balance. Also have suspension inspected. Suspension issues can also cause uneven tire wear such as tire cupping which causes noise and vibrations while driving.

As for idle, clean and replace parts. At 80K, it's time for new spark plugs. Check the throttle body and check PCV valve.