Kizashi Club

Your Kizashi Owners Club and Forum 

Ask technical questions or post on problems/issues related to the Kizashi under this topic. Symptoms and pictures of your problem are a good idea.
NOTE: Any car related technical question can be posted here.
 #49115  by chazyouwin
 Sun Apr 07, 2019 6:13 am
Has anyone dropped the bumper to replace headlights, then wondered how the underbody protective panel gets put back together competently with the bumper? I think the little pointed screws kept the underbody panel attached to the bumper, but now they seem shaky in that capacity. Maybe an extra clip-nut or a few?
 #49116  by BLyons
 Sun Apr 07, 2019 7:20 am
There are 6 screws total, and they should each have a clip. I lose a couple every year, but they always seem tight when I put them in, so I'm not sure what you mean when you say they're shaky.
 #49118  by chazyouwin
 Sun Apr 07, 2019 2:48 pm
When I took out these screws for my bought-new Kizashi, the only screws with a nut-clip were the ones holding the two little visor protective attachments at the front bottom of the bumper. The bumper and bottom plate plastic pieces were just screwed together with the same pointed wide round head Phillips screws. Yet they were strong enough, and I recall no work being done at any prior time (yes, my original low beam light bulbs lasted for 78,000 miles then went out at about the same time). But now that I am putting these items back together these connections seem shaky as the plate and the bumper down there are both flexible. I'll check on the clips, probably can use standards.
 #49119  by chazyouwin
 Sun Apr 07, 2019 4:41 pm
"they should each have a clip" - okay, that's the key. Found one of the clips got moved away on the panel and the other on the driveway. Mystery now confined to three screws, none of which is strictly necessary. Thanks!