Kizashi Club

Your Kizashi Owners Club and Forum 

Anything related to the Kizashi can go here, but please look at the other headings first. Your topic may fit better under something else.
 #44419  by NJKizashi161
 Fri Jun 23, 2017 4:24 pm
Hey Folks,
I dont post here much, but find this place a wealth of info for my Kizashi. My 2010 SLS 2WD Gray has, just today it hit 140,000 miles. I'm going to run it into the ground and ride this no car payment wave as much as I can.

it's had 25 oil changes at Approx. 5,000 miles without fail..so the engine is a Peach. But it no longer has the TPMS sensors, my Engine light goes on & off with a Mass flow sensor fault..I got a new sensor, with no fix, so frig it..it idles rough when hot during start up.

It's beat up, with dings, dents, scratches, headlights are sun faded, and it's still a Bitch to change the headlight bulbs...But it still going.

Anyway, I JUST, changed the CVT fluid, and actually when checking it, it didn't seem that dirty, but when I dumped it..it was Black...after 140k miles, I figured as much.

I put synthetic Valvoline CVT fluid, and it shifts much smoother and quicker, and the annoying 2 second wait time for the reverse to kick in is not as abrupt. :roll: ...But the Whine is still there, but it runs, so WTF...I'll deal with that too.

Next, I;ll flush the radiator...with 140k fluid in there it has never over heated or gone past the mid-way Hot Mark...

Anyway, just venting, but not really...Enjoy..Be Safe
 #44420  by Ronzuki
 Fri Jun 23, 2017 6:16 pm
Congrats. The purchase cost of the car figured in with the mileage you have combined w/ how little you've had to put in to it....I'd venture to say the car owes you nothing. Has it ever left you stranded along the side of the road? Probably not. It owes you nothing. I've never owned a zuk that had. Plenty of GMs have though. My AWD 2010's CVT w/ half the miles as yours whines a little...I just turn up the RF. When it dies, it dies. By then, ...it will owe me nothing.

Sounds more like a testament as opposed to a vent. Just sayin'.
 #44422  by dannytrfc
 Fri Jun 23, 2017 11:30 pm
im glad your kizashi is still strong!!, my 2012 AWD is close to 27000miles and also has the cvt whine noise, sometimes it can be very loud too, mine has been serviced by suzuki every year and they have told me not to worry about it, im from the UK so 'they probably dont like messing with cvt's' lol
 #44428  by NJKizashi161
 Sun Jun 25, 2017 6:07 pm
Bad News Update...The Kizashi now appears to be Dead. The Whine has gotten worse,, now it doesn't even get into gear, and when it seems to go into gear, it doesn't go more than (No Shit) 2-3 MPH...Even flooring the Gas, the engine wont Rev.
I shut the car down, re start it...then it Revs...back into Drive...it dies to less than a crawl, with the Weeeee/Whine ever louder. Fixing this thing, with a non-existent USA dealer network is futile and with 140,000miles,,,why bother :facepalm:

I'm done with buying anything else with a friggin CVT,,,prob my mistake with rolling the dice on a Goddamn car that they discontinue in the USA. :cry: :evil: :cry:

Anyway, I'm a Trump Guy, so I'm buying American..Maybe an F-150 or Explorer

Be Safe Folks,
 #44429  by Marcov71
 Sun Jun 25, 2017 7:19 pm
Wow, sorry to hear that man. Can't believe your problem got worse after changing the CVT fluid.
 #44433  by Ronzuki
 Mon Jun 26, 2017 5:31 pm
The process to change the fluid and correctly set the level in our CVTs is not a simple one. Read all about it in the FSM. A lot of opportunity to do it wrong (even for the "factory trained" guys). Incorrect level can be devastating to any trans let alone the fickle CVTs. Hence why I haven't bothered.
 #44436  by Triggerhappy
 Tue Jun 27, 2017 7:53 pm
Ronzuki wrote:The process to change the fluid and correctly set the level in our CVTs is not a simple one. Read all about it in the FSM. A lot of opportunity to do it wrong (even for the "factory trained" guys). Incorrect level can be devastating to any trans let alone the fickle CVTs. Hence why I haven't bothered.

Me either. If weshoot2 doesn't change the fluid, neither am I. :lol:
 #44437  by Ronzuki
 Wed Jun 28, 2017 5:30 pm
I think he did have #2's changed at some point if I recall correctly.