Kizashi Club

Your Kizashi Owners Club and Forum 

Anything related to the Kizashi can go here, but please look at the other headings first. Your topic may fit better under something else.
 #49629  by rossirob73
 Sun Jul 07, 2019 11:24 am
Hi All
I have been trying to get spotify working in my Kizashi.
My model is 2011 sport

My system is stock.

Is anyone else able to use spotify and how did you acheive this please.

Hello from Sydney Australia

Sent from my SM-G900I using Tapatalk
 #49632  by SAEED_KIZZY
 Sun Jul 07, 2019 6:24 pm
rossirob73 wrote:Hi All
I have been trying to get spotify working in my Kizashi.
My model is 2011 sport

My system is stock.

Is anyone else able to use spotify and how did you acheive this please.

Hello from Sydney Australia

Sent from my SM-G900I using Tapatalk

Hello,there are 2 ways to do that
first Buy android HeadUnit and install spotify also your HU must connect to internet through wifi hotspot or 3G dongle.
second way (better way) is to Use HU that support android Auto or iPhone Car Play in this solution you use your phone internet and app.
 #49634  by KuroNekko
 Sun Jul 07, 2019 9:06 pm
Spotify usability is all up to your phone and how you connect it to the car's audio. Saeed's suggestions require you to replace the head unit with something that syncs with your phone.

The cheap and easy way is to just connect the phone by cable and run Spotify. You said you have the stock audio system so do you have a USB or audio port input in the car?

Rockford Fosgate units without the navigation have Bluetooth Audio and this works very well with Spotify in my experience.
 #49636  by rossirob73
 Mon Jul 08, 2019 1:00 am
I do have usb
But when i place the cable in the error is USB unsupported.
It might only be for charging?

Sent from my SM-G900I using Tapatalk
 #49640  by rossirob73
 Mon Jul 08, 2019 10:02 pm
My phone has no issue in my wife's car via bluetooth.
for the Kizashi i think changing the head unit is the only option, as cables don't seem to work.
Thanks to the members whom have commented, much appreciated.
 #49698  by KuroNekko
 Tue Jul 16, 2019 3:23 am
rossirob73 wrote:My phone has no issue in my wife's car via bluetooth.
for the Kizashi i think changing the head unit is the only option, as cables don't seem to work.
Thanks to the members whom have commented, much appreciated.


Perhaps the USB port is damaged. Does it offer any power for recharging devices?
I think Bluetooth Audio streaming was only offered for the Rockford Fosgate system without navigation as a factory-installed unit.
 #49700  by rossirob73
 Tue Jul 16, 2019 4:08 am
I don't think the usb is damaged as it still seems to charge the phone. Pretty slow

I think maybe the cars exported to Australia didn't come with the abilty to play music.

I have found a different solution i just plug in a blue tooth speaker. Not ideal
But its ok to listen to podcasts.

Sent from my SM-G900I using Tapatalk