PLEASE HELP! Three codes--PO 271, PO 777, and P 1818--went off. Stuck, literally.

Let others know about your performance modifications, and help members find the parts they want.
Post Reply
KizaSheLover7
Posts: 2
Joined: Sat Mar 16, 2019 6:50 pm

Hi everyone:

I'm a longtime lurker and first time poster. I and my fiance own a 2010 Suzuki KIzashi SE 2.4 (AWD with an automatic transmission) and two weeks ago, while driving home, the check engine light went on as we made a sharp turn at about 25 mph. We barely made it home and the engine felt like it was clunking. That is the best I can describe it. (Also, a month and a half ago the code for the O2 sensor [Bank 1, Sensor 2] went on while on a turnpike going 70 MPH. We made it to an autozone, cleared the code, and the issue went away. Or did it?)

The codes that went off--PO 271, PO 777, and P 1818--were also cleared. After this, the car started acting different. However, it idles fine while not touching the accelerator pedal, but jerks and sputters when I try to drive forward or go in reverse. The RPM stays normal but it feels like the car lacks power and I am scared to try to take it somewhere.

I'm literally stuck. Does anyone know what the possible causes and fixes are? Any insight anyone can offer would be appreciated so much. I live in a more rural area in the mountains so there are only a few places I can take it. There is a dealership. Is the Suzuki dealership itself the best bet? How much more expensive would it be? Or, could it be fixed at a regular, but good garage?

Lastly, could the O2 sensor be causing these other codes to flip? Would fixing it fix the whole issue? Or is the car finished unless we invest thousands of dollars in it? It's worked well for a year and a half and it was maintained well and we kept up on it. I'm really hoping it is not the CVT, but one place said those codes point to the CVT.

PLEASE HELP A Suzuki GiIr OUt! :shock:
old tech
Posts: 720
Joined: Mon Apr 23, 2018 1:51 pm
Location: n/w pennsysvania

The p0777 and the p1818 are transmission pressure codes and are a pretty sure bet you need a transmission especially if there is clunking or a grabbing feeling . The p0271 is having to do with fuel injector on no 4 cyl or wiring to I think. Are there around 120,000 miles on it ? What area are you in?
User avatar
Quimicax
Posts: 36
Joined: Wed Mar 04, 2020 3:57 pm
Location: Dominican Republic

Codes P0777 and P1818 are related to each other indicates that the transmission may have an internal leak in the worst case :?
It would be good if you go to a mechanic specialized in CVT transmissions and have a test to measure the internal pressure
Kizashi GTS 2013 AWD
DRL Off / Foglights Without Headlights

Ford Explorer Sport 2013
350Rwhp

Nissan Xtrail 2017
KizaSheLover7
Posts: 2
Joined: Sat Mar 16, 2019 6:50 pm

It has a 125,000 miles or so on it. I'm in Northeastern PA, by scranton. How much would a new transmission cost? UGH. That's definitely it. I was hoping it was something else but I just tried to move it a little and it got stuck. No power to the wheels in drive or reverse; it only lurched. Plus, you could not push it in neutral. I loved the car but hate this. I will prolly have to get a used car as I imagine a transmission is expensive, no? Any estimates?
User avatar
Quimicax
Posts: 36
Joined: Wed Mar 04, 2020 3:57 pm
Location: Dominican Republic

KizaSheLover7 wrote:It has a 125,000 miles or so on it. I'm in Northeastern PA, by scranton. How much would a new transmission cost? UGH. That's definitely it. I was hoping it was something else but I just tried to move it a little and it got stuck. No power to the wheels in drive or reverse; it only lurched. Plus, you could not push it in neutral. I loved the car but hate this. I will prolly have to get a used car as I imagine a transmission is expensive, no? Any estimates?
Repair In My Country Cost Avg 1200 ~ 1800us Complete Unit Maybe 2000 ~ 2500 But Es Very Rare Find Parts Of Suzuki Here
Kizashi GTS 2013 AWD
DRL Off / Foglights Without Headlights

Ford Explorer Sport 2013
350Rwhp

Nissan Xtrail 2017
User avatar
Ronzuki
Posts: 2382
Joined: Wed Nov 17, 2010 5:33 pm
Location: Lancaster County, PA

old tech wrote: Are there around 120,000 miles on it ?
Seems to be the magic number neighborhood for the non-Japanese CVTs aye?
Ron

2010 Kizashi GTS, CVT, iAWD (3/10 build date)
2011 SX4 Premium Hatch, CVT, iAWD (12/10 build date)
2018 Mazda CX-5 iAWD Touring
2014 Wrangler JKUW (GONE, traded :D :D )
1991 Samurai, 5-Speed, EFI, Soft-Top ( :| sold)
old tech
Posts: 720
Joined: Mon Apr 23, 2018 1:51 pm
Location: n/w pennsysvania

I can offer you 2 low mile units . 28k mile unit installed ,new fluid , extra magnets and back to working perfectly at $1650 plus core. 1 yr warranty. 7k mile unit at $1950 same deal . Done here N/W pa. tow , if you cant find any better $500 to garage only.
Post Reply